» » Основы конфигурации Cisco PIX/ASA 8.2 с доступом в Интернет

Лаборатория Сетей Cisco
 
 
 

Основы конфигурации Cisco PIX/ASA 8.2 с доступом в Интернет

Автор: HunSolo от 3-07-2013, 18:03, посмотрело: 4501

0 Этот документ описывает наипростейшую конфигурацию, которая демонстрирует как установить Cisco Secure PIX/ASA Firewall для использования, как устройство доступа в интернет. Он включает установку уровней безопасности на интерфейсы, назначение IP адресов, конфигурацию динамической трансляции адресного пространства внутренней сети (inside) во внешнюю сеть (outside). Эта задача использует сетевую диаграмму показанную ниже.
Основы конфигурации Cisco PIX/ASA 8.2 с доступом в Интернет


В данном сетевом сценарии используются PIX/ASA для обеспечения доступа внутренней сети во внешнюю. R1 это роутер внутренней сети 10.1.1.0/24, а R2 это маршрутизатор для связи непосредственно с Интернет. R2 являться частью оборудования провайдера (ISP). Версия PIX/ASA 8.2 и ниже.

Конфигурация PIX/ASA 8.0

ASA Version 8.0(2) 
!
hostname ASA5520
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address 209.165.200.226 255.255.255.224 
!
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address 10.1.1.1 255.255.255.0 

! -- Трансляция внутренних адресов хостов во внешние (NAT). Определяем NAT пул
global (outside) 1 209.165.200.227-209.165.200.254 netmask 255.255.255.224

!--- Разрешаем всем внутренним хостам в использовать NAT или PAT
nat (inside) 1 0.0.0.0 0.0.0.0

!--- Указываем маршрут по умолчанию (default route) на ISP
route outside 0.0.0.0 0.0.0.0 209.165.200.225 1
ASA5520# 

Теперь с роутера R1 пропуем пропинговать Интернет адрес 1.1.1.1
Основы конфигурации Cisco PIX/ASA 8.2 с доступом в Интернет

Как видим ICMP пакеты успешно проходят. Теперь попробует проверить TCP протокол. Для этого выполним telnet на хост 1.1.1.1
Основы конфигурации Cisco PIX/ASA 8.2 с доступом в Интернет

И здесь тоже все хорошо. Мы смогли подключиться к порту. Посмотрим что происходит на ASA. Для выполним команду show xlate
Основы конфигурации Cisco PIX/ASA 8.2 с доступом в Интернет

Здесь мы видим, что наш хост 10.1.1.2 транслируется в адрес 209.165.200.227 - т.е пула внешних адресов, выданных нам сервис-провайдером. Также команда show conn - показывает установленное в настоящее время telnet (TCP порт 23) соединение на хост 1.1.1.1 с нашего хоста 10.1.1.2

В заключении приведем аналогичную конфигурацию PIXа для версии 6.3(5)

Конфигурация PIX 6.3

!-- Уровни безопасности на интерфейсах. Уровень 100 - наивысший.
!-- Как правило интерфейс с нивысшим уровнем подключается к внутренней сети.

nameif ethernet0 outside security0
nameif ethernet1 inside security100

!--- Назначаем адреса на интерфейсы
ip address outside 209.165.200.226 255.255.255.224
ip address inside 10.1.1.1 255.255.255.0

! -- Трансляция внутренних адресов хостов во внешние (NAT)
global (outside) 1 209.165.200.227-209.165.200.254 netmask 255.255.255.224
nat (inside) 1 0.0.0.0 0.0.0.0 0 0

!-- Устанавливаем маршрут по умолчанию на Router
route outside 0.0.0.0 0.0.0.0 209.165.200.225 1




Категория: Безопасность и VPN

Уважаемый посетитель, Вы зашли на сайт как незарегистрированный пользователь.
Мы рекомендуем Вам зарегистрироваться либо войти на сайт под своим именем.

Добавление комментария

Имя:*
E-Mail:
Комментарий:
Полужирный Наклонный текст Подчеркнутый текст Зачеркнутый текст | Выравнивание по левому краю По центру Выравнивание по правому краю | Вставка смайликов Выбор цвета | Скрытый текст Вставка цитаты Преобразовать выбранный текст из транслитерации в кириллицу Вставка спойлера
Вопрос:
Под водой живёт народ, Ходит задом наперёд
Ответ:*
Введите два слова, показанных на изображении: *