» » Базовая конфигурация роутера для доступа в Интернет

Лаборатория Сетей Cisco
 
 
 

Базовая конфигурация роутера для доступа в Интернет

Автор: HunSolo от 1-07-2013, 15:46, посмотрело: 5008

2 Этот документ описывает как использовать Командный Интерфейс роутера (Command Line Interface, CLI) чтобы установить базовую конфигурацию. Он включает назначение IP адресов, установку маршрута по умолчанию, создание статического и динамического NAT (трасляция внутренних адресов хостов), задание имени роутера, приветственного сообщения (banner), создание пользовательского аккаунта и установку пароля доступа к роутеру по сети. Сетевая диаграмма показана на рисунке ниже
Базовая конфигурация роутера для доступа в Интернет


В качестве роутера используется Cisco 3640 c IOS 12.4.

Фрагмент конфигурации 3640:

!--- Создаем пользовательский аккаунт sdmsdm со всеми привилениями
username sdmsdm privilege 15 password 0 sdmsdm
!
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!

!--- Интерфейс LAN конфигурируется IP адресом из приватного диапазона.
interface FastEthernet1/0
ip address 172.16.1.2 255.255.255.0

!--- Трафик который приходит на этот интефейс является объектом для трансляции (NAT)
ip nat inside

duplex auto
speed auto
!

!--- Это WAN интерфейс, конфигурируется маршрутизируемым (публичным) IP адресом.
interface Serial2/0
ip address 192.168.1.1 255.255.255.0

!--- Обозначим, что этот интерфейс приемником для трафика, который подвергся NAT
ip nat outside

!--- Далее следует конфигурация для динамического NAT.
!
!--- Определим пул внешних IP адресов для NAT.
ip nat pool pool1 192.168.1.3 192.168.1.10 netmask 255.255.255.0

!--- Для того, чтобы разрешить NAT для внутренних SRC адресов, указываем, что трафик от хостов
!---которые попадают под access list 1, транслируются в адресный пул с именем pool1
ip nat inside source list 1 pool pool1


!--- Access list 1 дозволяет транслировать только сеть 172.16.1.0
access-list 1 permit 172.16.1.0 0.0.0.255

!--- Это конфигурация для статического NAT

!--- Для того, чтобы транслировать пакеты между внутренним IP адресом 172.16.1.1 TCP порт 80
!--- и преобразованным IP адресом 192.168.1.1 TCP порт 500.
ip nat inside source static tcp 172.16.1.1 80 192.168.1.3 500 extendable

!--- Маршрут по умолчанию указывает на 192.168.1.2.
ip route 0.0.0.0 0.0.0.0 192.168.1.2

!--- Статический путь указывает тоже на 192.168.1.2.
ip route 10.1.1.0 255.255.255.0 192.168.1.2
!
line con 0
line aux 0

!--- Разрешает telnet к роутеру и устанавливаем пароль sdmsdm.
line vty 0 4
password sdmsdm
login
!
!
end





Категория: Маршрутизация

Уважаемый посетитель, Вы зашли на сайт как незарегистрированный пользователь.
Мы рекомендуем Вам зарегистрироваться либо войти на сайт под своим именем.
<
  • 1 комментарий
  • 0 публикаций
  • ICQ:
12 февраля 2014 09:56

Moiseev777

Цитата
  • Группа: Посетители
  • Регистрация: 9.01.2014
  • Статус: Пользователь offline
 
а.. сеть 10.1.1.0 что за сеть?

<
  • 0 комментариев
  • 0 публикаций
  • ICQ:
16 сентября 2014 18:01

a1exander

Цитата
  • Группа: Гости
  • Регистрация: --
  • Статус:
 
Это IP, который в облачко заходит. То есть ISP'шный адрес.

Сорри... Не адрес, а удаленная подсеть.


Добавление комментария

Имя:*
E-Mail:
Комментарий:
Полужирный Наклонный текст Подчеркнутый текст Зачеркнутый текст | Выравнивание по левому краю По центру Выравнивание по правому краю | Вставка смайликов Выбор цвета | Скрытый текст Вставка цитаты Преобразовать выбранный текст из транслитерации в кириллицу Вставка спойлера
Вопрос:
Сам худ, а голова с пуд
Ответ:*
Введите два слова, показанных на изображении: *