» » Технология расщепление горизонта Split horizon

Лаборатория Сетей Cisco
 
 
 

Технология расщепление горизонта Split horizon

Автор: HunSolo от 11-07-2013, 22:21, посмотрело: 6765

1 Для предотвращения появления петель маршрутизации и зацикливания пакетов протоколы маршрутизации используют метод расщепления горизонта или split horizon. В этой статье мы попытаемся пролить свет именно на эту технологию.

Согласно технологии Split-Horizon маршрутизатор не будет распространять информацию об определенном маршруте через интерфейс, который является источником данной информации. Другими словами, маршрутизатор не будет информировать о достижимости получателя своего соседа, от которого была получена информация о маршруте к получателю.

Использование метода расщепления горизонта основано на том, что , как правило, нет необходимости в отправке информации о маршруте в обратном направлении, точнее в том направлении, по которому этот маршрут поступил. С точки зрения здравого смысла и правил маршрутизации такой подход является оптимальным. Но в некоторых конфигурациях сетей может оказаться целесообразным НЕ использовать механизм расщепления горизонта и необходимо отключать его. Отключение производится для каждого интерфейса отдельно. Примером когда требуется отключать технологию split-horizon может являться динамическая маршрутизация в DMVPN сетях, Frame-Relay Point-to-Multipoint сетях и т.п

Рассмотрим традиционную сетевую топологию - типа звездочка.

Технология расщепление горизонта Split horizon

В центре у нас R1 (Хаб), а роутеры R2 и R3 подключены к нему, через frame-relay облако по технологии Point-to-Multipoint.

Конфигурация R1
interface FastEthernet0/0
 ip address 1.0.0.1 255.0.0.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
!
interface Serial0/0.1 multipoint
 ip address 10.0.0.1 255.0.0.0
 frame-relay map ip 10.0.0.3 103 broadcast
 frame-relay map ip 10.0.0.2 102 broadcast
!
router rip
 version 2
 network 1.0.0.0
 network 10.0.0.0
!


Конфигурация R2
interface FastEthernet0/0
 ip address 4.0.0.1 255.0.0.0
!
interface Serial0/0
 ip address 10.0.0.2 255.0.0.0
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 10.0.0.3 201
 frame-relay map ip 10.0.0.1 201 broadcast
!
!
router rip
 version 2
 network 4.0.0.0
 network 10.0.0.0
!


Конфигурация R3
interface FastEthernet0/0
 ip address 5.0.0.1 255.0.0.0
!
interface Serial0/0
 ip address 10.0.0.3 255.0.0.0
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 10.0.0.2 301
 frame-relay map ip 10.0.0.1 301 broadcast
!
router rip
 version 2
 network 5.0.0.0
 network 10.0.0.0
!


Все роутеры обмениваются между собой машрутами с помощью протокола динамической маршрутизации RIP. Взглянем на таблицу маршрутизации роутера R1

Технология расщепление горизонта Split horizon

Из вывода мы видим что хосты из сети 1.0.0.0/8 могут взаимодействовать со всеми сетями R2 и R3 (4.0.0.0/8 и 5.0.0.0/8). Но посмотрим, могут ли сети R2 и R3 обмениваться между собой. Таблица маршрутизации на R2 выглядит:

Технология расщепление горизонта Split horizon

Но из следующего вывода видно что маршрутизаторы R2 и R3 не получают информацию друг о друге и следовательно сети 4.0.0.0/8 и 5.0.0.0/8 не взаимодействуют!

Посмотрим вывод команды show ip interface s0/0.1 на R1
Технология расщепление горизонта Split horizon

В силу вступила технология расщепления горизонта, тем самым заблокировав работу сети. Маршрутная информация, приходя на R1 не уходила дальше, так как во всех этих процессах был задействован один и тот же интерфейс (s0/0.1), который был и приемником и передатчиком для сетей 4.0.0.0/8 и 5.0.0.0/8

Для исправления этой ситуации следует отменить split horizon на интерфейсе Serial0/0.1 маршрутизатора R1 с помощью команды no ip split-horizon

R1(config)#int s0/0.1
R1(config-subif)#no ip split-horizon


После чего маршрутная информация сможет распространятся из того же интерфейса на котором она была принятаПосмотрим теперь таблицу маршрутизации на R2

Технология расщепление горизонта Split horizon

Теперь R2 и R3 знают друг о друге, так как в их таблицах роутинга приличествуют сети друг друга.



Категория: Маршрутизация

Уважаемый посетитель, Вы зашли на сайт как незарегистрированный пользователь.
Мы рекомендуем Вам зарегистрироваться либо войти на сайт под своим именем.
<
  • 0 комментариев
  • 0 публикаций
  • ICQ:
20 октября 2014 09:55

The.death

Цитата
  • Группа: Гости
  • Регистрация: --
  • Статус:
 
В вашем примере показано как технология расщепления горизонта мешает работе сети, а есть ли у вас примеры, где без этой технологии реально не обойтись, где показано как она нужна и полезна при построении сети?


Добавление комментария

Имя:*
E-Mail:
Комментарий:
Полужирный Наклонный текст Подчеркнутый текст Зачеркнутый текст | Выравнивание по левому краю По центру Выравнивание по правому краю | Вставка смайликов Выбор цвета | Скрытый текст Вставка цитаты Преобразовать выбранный текст из транслитерации в кириллицу Вставка спойлера
Вопрос:
Имя первой женщины в мире, освоившей летательный аппарат
Ответ:*
Введите два слова, показанных на изображении: *