» » Понимание полиси роутинга PBR

Лаборатория Сетей Cisco
 
 
 

Понимание полиси роутинга PBR

Автор: HunSolo от 6-07-2013, 23:53, посмотрело: 3112

0 Полиси роутинг (Policy Base Routing, PBR) дает инструмент для пересылки и маршрутизации пакетов основываясь на политике, определенной сетевым администратором. По сути это способ, посредством которого, переопределяется решение протокола маршрутизации. Полиси роутинг включает в себя механизм для выборочного применения политики основываясь на листах доступа (access list), размере пакета или других критериев. Действие принятое политикой может включать маршрутизацию пакетов по одному или нескольким пользовательским маршрутам, выставление приоритетов, битов TOS и т.д.

В данном документе, чтобы транслировать приватные адреса 10.0.0.0/8 в маршрутизируемые адреса используется Firewall
Понимание полиси роутинга PBR

В этом примере, при обычной маршрутизации, все пакеты из сети 10.0.0.0/8, идущие в Интернет к R3, будут использовать путь через интерфейс fa0/1 Cisco R2 (через подсеть 172.16.189.0/24), так как он является лучшем путем с наименьшей метрикой. С полиси роутингом, мы хотим, чтобы эти пакеты ходили через Firewall в Интернет. Поведение обычного роутинга должно быть переопределено конфигурацией полиси роутинга. Firewall транслирует все пакеты идущие в Интернет из сети 10.0.0.0/8, что не является необходимым для работы полиси роутинга.

В этом примере на R2 работает PBR, чтобы гарантировать, что пакеты идущие из сети 10.0.0.0/8 будут посланы через Firewall. Приведенная конфигурация содержит лист доступа (ACL), определяющий пакеты, которые будут посланы по другому маршруту.

access-list 111 permit ip 10.0.0.0 0.255.255.255 any


Далее объявлен route-map (маршрутная карта), в которой определно, что делать с пакетами попадающими в лист доступа 111.
route-map net-10 permit 10
 match ip address 111
 set interface FastEthernet1/0

Мы используем правило set interface, чтобы послать эти пакеты через интефейс FastEthernet1/0. И заключении, вешаем нашу карту на входящий интерфейс fa0/0 маршрутизатора R2
interface FastEthernet0/0
  ip policy route-map net-10


Конфигурация Cisco R2


interface FastEthernet0/1
 ip address 172.16.189.3 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet1/0
 ip address 172.16.39.3 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 172.16.79.3 255.255.255.0
 no ip directed-broadcast
 ip policy route-map net-10
!
router eigrp 1
 network 172.16.0.0
!

access-list 111 permit ip 10.0.0.0 0.255.255.255 any
!
route-map net-10 permit 10
 match ip address 111
 set interface FastEthernet1/0
!




Категория: Маршрутизация

Уважаемый посетитель, Вы зашли на сайт как незарегистрированный пользователь.
Мы рекомендуем Вам зарегистрироваться либо войти на сайт под своим именем.

Добавление комментария

Имя:*
E-Mail:
Комментарий:
Полужирный Наклонный текст Подчеркнутый текст Зачеркнутый текст | Выравнивание по левому краю По центру Выравнивание по правому краю | Вставка смайликов Выбор цвета | Скрытый текст Вставка цитаты Преобразовать выбранный текст из транслитерации в кириллицу Вставка спойлера
Вопрос:
Ночью не спит, Мышей сторожит
Ответ:*
Введите два слова, показанных на изображении: *