» » Введение в протокол RIP

Лаборатория Сетей Cisco
 
 
 

Введение в протокол RIP

Автор: HunSolo от 5-07-2013, 13:46, посмотрело: 9619

0 Routing Information Protocol (RIP) использует широковещательные User Datagram Protocol (UDP) пакеты данных для обмена маршрутной информацией. Программное обеспечение Cisco IOS посылает маршрутные обновления каждые 30 секунд, это называется вещаением или рассылкой (advertising). Если маршрутизатор не получает обновления от другого маршрутизатора в течение 180 секунд или более, он помечает маршруты обслуживаемые необновляемым маршрутизатором как непригодные. Если через 240 секунд до сих пор нет обновления , маршрутизатор удаляет все записи в таблице маршрутизации для не обновляемого маршрутизатора
Введение в протокол RIP


Маршрутизатор под управлением RIP может получить сеть по умолчанию с помощью обновлений от другого маршрутизатора, на котором работает RIP, или маршрутизатор может быть сам источником (генерировать) сети по умолчанию посредством RIP. В обоих случаях, сети по умолчанию вещаются через RIP другим RIP - соседям.
Реализация Cisco RIP версии 2 поддерживает обычную текстовую и Message Digest 5 (MD5) аутентификацию, суммирование маршрутов, бесклассовую междоменной роутинг (CIDR) и подсети с маской переменной длины (VLSMs).

RIP обновления

RIP использует единственную метрику маршрутизации, чтобы измерить расстояние между источником и сетью назначения и называется hop count. Число прыжков (hop count) - это количество маршрутизаторов, через которые может пройти пакет по данному маршруту. Каждому хопу в пути от источника к получателю присваивается значение числа переходов, которое, как правило, равно 1. Когда маршрутизатор получает обновление маршрутной информации, которая содержит новую или измененную запись об адресате, маршрутизатор добавляет 1 к значению метрики указанную в обновлении и пишет сеть в таблицу маршрутизации. IP-адрес отправителя используется в качестве следующего хопа. Непосредственно подключеная сеть к маршрутизатору имеет метрику нуль; недоступные сети имеет метрику 16. Этот небольшой диапазон метрики RIP делает непригодными протокол маршрутизации для больших сетей. Если сеть сетевого интерфейса не указана, она не будет вещаться ни в каком RIP обновлении.

RIP версии 1 и RIP версия 2 и аутентификация

RIP v.1 не поддерживает маски, т. е. он распространяет между маршрутизаторами информацию только о номерах сетей и расстояниях до них, но не о масках этих сетей, считая, что все адреса принадлежат к стандартным классам A, B или С. RIP v.2 передает данные о масках сетей, поэтому он в большей степени соответствует современным требованиям.
По умолчанию, Cisco IOS умеет принимать только RIP пакеты версий 1 и 2, но отправляет только версии 1. Вы можете настроить IOS, чтобы получать и отправлять только пакеты версии 1. Кроме того, вы можете настроить IOS, чтобы получать и отправлять пакеты только версии 2. Чтобы переопределить поведение по умолчанию, вы можете указать, какие RIP версии посылать интерфейсу. Кроме того, вы также можете управлять тем, как обрабатываются пакеты, полученные от интерфейса .
RIP версии 1 не поддерживает аутентификацию. Если вы отправляете и получаете RIP Version 2 , вы можете включить проверку подлинности RIP на интерфейсе.
Ключевой блок (Key Chain) определяет набор ключей, которые можно использовать на интерфейсе. Если Ключевой блок не настроен проверка подлинности не выполняется на этом интерфейсе.
Мы поддерживаем два режима проверки подлинности на интерфейсе, для которого включена RIP аутентификация: простая текстовая аутентификация и аутентификация MD5. Проверка подлинности по умолчанию в каждом пакете RIP версии 2 является простой текстовой аутентификацией.

Конфигурация RIP


Все что необходимо сделать на IOS маршрутизаторе это объявить интерфейсы которые участвуют в RIP через команду network и включить сам протокол RIP на устройстве. Используем рисунок на диаграмме выше

Конфигурация R1
interface FastEthernet0/0
 ip address 1.0.0.1 255.255.0.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 12.0.0.1 255.255.0.0
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 12.0.0.2 102 broadcast

!-- Включаем протокол RIP
router rip

!-- Объявляем интерфейсы которые участвуют в RIP
 network 1.0.0.0
 network 12.0.0.0
!


Конфигурация R2
interface FastEthernet0/0
 ip address 2.0.0.2 255.255.0.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 12.0.0.2 255.255.0.0
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 12.0.0.1 201 broadcast

!-- Включаем протокол RIP
router rip

!-- Объявляем интерфейсы которые участвуют в RIP
 network 2.0.0.0
 network 12.0.0.0
!


Посмотрим на таблицу маршрутизации роутера R1

Введение в протокол RIP

Здесь мы видим, что R1 изучил сеть 2.0.0.0/8 от роутера R2. Также заметим, что R2 на самом деле имеет сеть 2.0.0.0/16 на своем Fa0/0 интерфейсе. Но по умолчанию R2 высылает апдейты RIP версии 1, в котором нем понятия маски, а сеть 2.0.0.0 - является сетью класса A, а значит имеет маску 255.0.0.0.

Включив debug ip rip на маршрутизаторе, мы можем посмотреть как происходят обновления маршрутной информации

Введение в протокол RIP

Здесь мы наблюдаем периодическую рассылку полной маршрутной информации, которая происходит каждые 30 сек. На следующей страницы можно более подробно ознакомится с принципами Обмена маршрутной Информацией между RIP-маршрутизаторами

Обмен маршрутной Информацией

К появлению новых маршрутов маршрутизаторы RIP приспосабливаются без труда: в очередном сообщении своим соседям они передают новую информацию, так что та постепенно становится известна всем маршрутизаторам сети. А вот к отрицательным изменениям, связанным с потерей какого-либо маршрута, им адаптироваться сложнее. Дело в том, что в формате сообщений протокола RIP нет поля, где бы содержалась информация об отсутствии пути к данной сети.
Понятно, что некоторый маршрут более недействителен, можно двумя способами:
- на основании истечения времени жизни маршрута;
- указанием специального расстояния до сети, ставшей недоступной, а именно — бесконечности.
Для реализации первого механизма каждая запись таблицы маршрутизации, полученная по протоколу RIP, имеет время жизни (TTL). При поступлении очередного сообщения RIP с подтверждением того, что данная запись действительна, таймер TTL устанавливается в исходное состояние, а затем из него каждую секунду вычитается единица. Если за время тайм-аута не придет новое маршрутное сообщение об этом маршруте, то он отмечается как недействительный.
Время ожидания связано с периодом рассылки векторов по сети. Период рассылки в RIP равен 30 с, а в качестве тайм-аута принято шестикратное значение периода рассылки, т. е. 180 с. Шестикратный запас времени нужен для уверенности в том, что проблемы заключаются не в потерях сообщений RIP (а это возможно, так как RIP использует транспортный протокол UDP, который не гарантирует доставку сообщений), а в том, что сеть действительно стала недоступна. Если какой-либо маршрутизатор выходит из строя, то через 180 с все порожденные этим маршрутизатором записи станут недействительными у его ближайших соседей. После этого процесс повторится уже для соседей ближайших соседей — они вычеркнут подобные записи через 360 с, так как первые 180 с ближайшие соседи еще передавали сообщения об этих записях. Как видим, сведения о недоступных через отказавший маршрутизатор сетях распространяются по сети не очень быстро, время распространения кратно времени жизни записи, а коэффициент кратности равен количеству транзитных узлов между самыми дальними маршрутизаторами сети. В этом и заключается одна из причин выбора в качестве периода рассылки небольшой величины в 30 с.
Если сбой происходит лишь на одном из интерфейсов маршрутизатора или в сети, через которую он связан с каким-либо соседом, то ситуация сводится к только что описанной — механизм тайм-аута вновь приводится в действие, и ставшие недействительными маршруты постепенно будут вычеркнуты из всех маршрутизаторов сети.

Тайм-аут работает в тех случаях, когда маршрутизатор не может послать соседям сообщение о недоступном маршруте по причине собственной неработоспособности либо неработоспособности линии связи, по которой можно было бы передать сообщение.
Если пересылка возможна, то маршрутизаторы RIP не используют специальный признак в сообщении, а указывают бесконечное расстояние до сети, причем в протоколе RIP оно выбрано равным 16 транзитным узлам (при использовании другой метрики маршрутизатору необходимо указать ее значение, считающееся бесконечностью). При поступлении сообщения, в котором расстояние до некоторой сети равно 16 (или 15, что приводит к тому же результату, так как полученное значение увеличивается на 1), маршрутизатор должен проверить, исходит ли эта «негативная» информация о сети от того же маршрутизатора, сообщение которого послужило в свое время основанием для записи о данной сети в таблице маршрутизации. Если это так, то информация считается достоверной, и маршрут отмечается как недоступный.
Значение «бесконечного» расстояния задается столь небольшим потому, что в некоторых случаях перебои в линиях связи вызывают длительные периоды некорректной работы маршрутизаторов RIP, выражающейся в зацикливании пакетов в петлях сети. И чем меньше расстояние, используемое в качестве «бесконечного», тем такие периоды становятся короче.
Ограничение в 15 транзитных узлов сужает область применения протокола RIP до сетей, в которых число промежуточных маршрутизаторов не должно превышать 15. Для более масштабных сетей нужно использовать другие протоколы маршрутизации, например OSPF, или разбивать сеть на автономные области.

Методы борьбы с ложными маршрутами в протоколе RIP

Несмотря на то что протокол RIP не способен полностью исключить переходные состояния в сети, когда некоторые маршрутизаторы пользуются устаревшей информацией о несуществующих уже маршрутах, отчасти подобные проблемы решаются при помощи специальных методов.
Так, трудности, возникающие от появления петли между соседними маршрутизаторами, предотвращаются с помощью метода, получившего название «расщепление горизонта» (split horizon). Он заключается в том, что маршрутная информация о некоторой сети, хранящаяся в таблице маршрутизации, никогда не передается маршрутизатору, от которого она получена (это тот маршрутизатор, который является следующим в данном маршруте).
Однако расщепление горизонта не помогает в тех случаях, когда петли образуют не два, а несколько маршрутизаторов.
Для предотвращения зацикливания пакетов по составным петлям при отказах связей применяется два других приема, называемых «принудительные обновления» (triggered update) и «замораживание изменений» (hold down).
Способ принудительных обновлений состоит в том, что, получив данные об изменении метрики до какой-либо сети, маршрутизатор не ждет истечения периода передачи таблицы маршрутизации, а передает данные об изменившемся маршруте немедленно. Этот прием помогает во многих случаях предотвратить передачу устаревших сведений об отказавшем маршруте, но он перегружает сеть служебными сообщениями, поэтому принудительные объявления также делаются с некоторой задержкой. В связи с этим возможна ситуация, когда регулярное обновление на каком-либо маршрутизаторе опередит поступление принудительного обновления от предыдущего маршрутизатора в цепочке, и данный маршрутизатор успеет передать по сети устаревшую информацию о несуществующем маршруте.
Второй прием позволяет исключить подобные ситуации. Он связан с введением тайм-аута на принятие новых данных о только что ставшей недоступной сети и предотвращает принятие устаревших сведений о конкретном маршруте от тех из них, кто находится на некотором расстоянии от отказавшей связи и передает устаревшие сведения о ее работоспособности. Предполагается, что в течение тайм-аута замораживания изменений эти маршрутизаторы вычеркнут данный маршрут из своих таблиц, так как не получат о нем новых записей и не будут распространять устаревшую информацию.



Категория: Маршрутизация

Уважаемый посетитель, Вы зашли на сайт как незарегистрированный пользователь.
Мы рекомендуем Вам зарегистрироваться либо войти на сайт под своим именем.

Добавление комментария

Имя:*
E-Mail:
Комментарий:
Полужирный Наклонный текст Подчеркнутый текст Зачеркнутый текст | Выравнивание по левому краю По центру Выравнивание по правому краю | Вставка смайликов Выбор цвета | Скрытый текст Вставка цитаты Преобразовать выбранный текст из транслитерации в кириллицу Вставка спойлера
Вопрос:
Раскаленная стрела дуб свалила у села
Ответ:*
Введите два слова, показанных на изображении: *