» » Базовая конфигирация OSPF на Ethernet

Лаборатория Сетей Cisco
 
 
 

Базовая конфигирация OSPF на Ethernet

Автор: HunSolo от 3-07-2013, 21:50, посмотрело: 2817

0 Данный документ объясняет как конфигурировать протокол динамической маршрутизации Open Shortest Path First (OSPF) на широковещательной (broadcast) среде, такой как Ethernet. Для ознакомления с протоколом OSPF и его работой рекомендуется обратится к статье Введение в протокол OSPF, а также к документу Состояния OSPF соседей ранее опубликованных на CiscoLAB. В этой статье используется следующая сетевая диаграмма

Базовая конфигирация OSPF на Ethernet

Три маршрутизатора R1, R2 и R3 подключены к сетевой среде Ethernet своими интерфейсами на которые назначены IP адреса 10.10.10.1/24, 10.10.10.2/24 и 10.10.10.3/24 соответственно.

Конфигурация R1

interface Loopback0
 ip address 192.168.45.1 255.255.255.0

interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0

!--- Протокол OSPF настроен для работы на интерфейсе Ethernet c Area ID  0.
router ospf 1
network 10.10.10.0 0.0.0.255 area 0
network 192.168.45.0 0.0.0.255 area 0


Конфигурация R2

interface Loopback0
 ip address 172.16.10.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.10.10.2 255.255.255.0
!
!--- Протокол OSPF настроен для работы на интерфейсе Ethernet c Area ID  0.
router ospf 1
network 10.10.10.0 0.0.0.255 area 0
network 172.16.10.0 0.0.0.255 area 0


Конфигурация R3
interface Loopback0
 ip address 150.1.1.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.10.10.3 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 10.10.10.0 0.0.0.255 area 0
 network 150.1.1.0 0.0.0.255 area 0


Команда show ip ospf neighbor покажет нам информацию об OSPF-соседях.

Базовая конфигирация OSPF на Ethernet

Из этого вывода видно, что состояние соседа является FULL на роутере R1 по отношению к R2, который имеет Neighbor ID 172.16.10.1. R2 - это резервный роутер (Backup Designated Router, BDR) в этой широковещательной сети.

Базовая конфигирация OSPF на Ethernet

А маршрутизатор R1 - это Основной роутер (Designated Router, DR) в этой широковещательной сети.

Команда show ip ospf interface покажет разнообразную информацию связанную с OSPF интерфейсом. Выполним ее на R1
Базовая конфигирация OSPF на Ethernet

Из этого вывода мы видим, что типом сети для интрефейса FastEthernet0/0 является BROADCAST

После установления OSPF соседства, таблица маршрутизации на R1 выглядит следующим образом:
Базовая конфигирация OSPF на Ethernet

Как видно из данного вывода, роутер изучил маршрут на сеть 172.16.10.1/32 от своего соседа через протокол OSPF и теперь мы можем проверить связность с этой сетью.

Таблица маршрутизации на R2 выглядит аналогично.
Базовая конфигирация OSPF на Ethernet

Здесь также роутер R2 выучил маршруты к R1 и R3 через OSPF и может отвечать на пакеты посланные с адреса 192.168.45.1/32



Категория: Маршрутизация

Уважаемый посетитель, Вы зашли на сайт как незарегистрированный пользователь.
Мы рекомендуем Вам зарегистрироваться либо войти на сайт под своим именем.

Добавление комментария

Имя:*
E-Mail:
Комментарий:
Полужирный Наклонный текст Подчеркнутый текст Зачеркнутый текст | Выравнивание по левому краю По центру Выравнивание по правому краю | Вставка смайликов Выбор цвета | Скрытый текст Вставка цитаты Преобразовать выбранный текст из транслитерации в кириллицу Вставка спойлера
Вопрос:
Круглое, румяное, я расту на ветке; Любят меня взрослые и маленькие детки
Ответ:*
Введите два слова, показанных на изображении: *