Конференция CiscoLab: Два Isp Через Nat На Cisco 1751 - Конференция CiscoLab

Перейти к содержимому

Страница 1 из 1
  • Вы не можете создать новую тему
  • Вы не можете ответить в тему

Два Isp Через Nat На Cisco 1751

#1 Пользователь офлайн   fidonet Иконка

  • Новичок
  • Pip
  • Вставить ник
  • Цитировать
  • Раскрыть информацию
Репутация: 0
Обычный

Отправлено 10 Сентябрь 2015 - 11:08

Всем привет!

Есть два провайдера: онлайм (основной, 11-й влан) и билайн (резервный, 9-й влан).
Оба выдают дефолтный шлюз и белый динамический IP по DHCP.
Собрал схему с отслеживанием живости основного канала через трекинг (ip sla), который инсталлирует в GRT дефолтный маршрут с лучшей метрикой, чем у резервного. Когда основной падает, маршрут убирается, остается с худшей метрикой, очищаются трансляции NAT по EEM и трафик начинает идти по резервному, пока не поднимется основной. Всё работает, но шлюз для основного мне пришлось прописать явно в ручную, т.к. трекинг маршрута, полученного по DHCP не получается настроить. Т.е. такую команду IOS не принимает:
ip route 0.0.0.0 0.0.0.0 f0/0.11 DHCP 250 track 1
Пока я его прописал в ручную статически:
ip route 0.0.0.0 0.0.0.0 5.228.32.1 250 track 1
Но адрес шлюза у онлайма вполне может измениться в любой время.
Как автоматизировать данный процесс, есть у кого какие мысли?

Далее инфо по железу с софтом и выдержка из конфига, имеющего отношение к вышеописанному:
Cisco IOS Software, C1700 Software (C1700-ADVSECURITYK9-M), Version 12.4(15)T14, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Tue 17-Aug-10 19:11 by prod_rel_team

ROM: System Bootstrap, Version 12.2(1r)XE1, RELEASE SOFTWARE (fc1)
System image file is "flash:c1700-advsecurityk9-mz.124-15.T14.bin"

Cisco 1751-V (MPC860P) processor (revision 0x300) with 81920K/16384K bytes of memory.
Processor board ID FOC07320EPY (2654918311), with hardware revision 0000
MPC860P processor: part number 5, mask 2
1 FastEthernet interface
32K bytes of NVRAM.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Конфиг:
[...]
ip dhcp pool LAN
network 172.16.10.0 255.255.255.192
default-router 172.16.10.62
dns-server 77.37.251.33 85.21.192.3
lease 0 8
!
track 1 rtr 1 reachability
!
!
!
interface FastEthernet0/0
no ip address
load-interval 30
speed auto
!
interface FastEthernet0/0.5
encapsulation dot1Q 5
ip address 172.16.10.62 255.255.255.192
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly max-fragments 64
no cdp enable
!
interface FastEthernet0/0.9
encapsulation dot1Q 9
ip address dhcp
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
no cdp enable
!
interface FastEthernet0/0.11
encapsulation dot1Q 11
ip address dhcp
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 5.228.32.1 250 track 1
ip route 77.88.21.3 255.255.255.255 5.228.32.1
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0.9 dhcp 251
!
!
no ip http server
no ip http secure-server
ip nat inside source route-map beeline interface FastEthernet0/0.9 overload
ip nat inside source route-map onlime interface FastEthernet0/0.11 overload
!
ip access-list extended lan-onlime
permit ip 172.16.10.0 0.0.0.127 any
!
ip sla 1
icmp-echo 77.88.21.3 source-interface FastEthernet0/0.11
timeout 2500
threshold 2000
frequency 5
ip sla schedule 1 life forever start-time now
logging trap debugging
!
!
route-map onlime permit 10
match ip address lan-onlime
match interface FastEthernet0/0.11
!
route-map beeline permit 10
match ip address lan-onlime
match interface FastEthernet0/0.9
!
!
[...]
event manager applet clear_nat
event oir
event manager applet 1
event track 1 state any
action 1.0 cli command "enable"
action 2.0 cli command "clear ip nat trans forced"
!

0

#2 Пользователь офлайн   HunSolo Иконка

  • Администратор
  • Вставить ник
  • Цитировать
  • Раскрыть информацию
Репутация: 4
Обычный

Отправлено 10 Сентябрь 2015 - 17:06

Посмотрите в строну
ip dhcp client route track
http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr/command/ipaddr...ml#wp7805944750
0

#3 Пользователь офлайн   fidonet Иконка

  • Новичок
  • Pip
  • Вставить ник
  • Цитировать
  • Раскрыть информацию
Репутация: 0
Обычный

Отправлено 11 Сентябрь 2015 - 15:39

Просмотр сообщенияHunSolo (10 Сентябрь 2015 - 17:06) писал:

Посмотрите в строну
ip dhcp client route track
http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr/command/ipaddr...ml#wp7805944750

Спасибо, но не подошло. Маршрут к 77.88.21.3 тоже пришлось прописывать через DHCP track и когда он отваливался, то потом уже не восстанавливался (трекер уходил в перманентный down). Но решение-таки нашлось:
При помощи EEM:
event manager applet onlime-down
event track 1 state down
action 1.0 cli command "enable"
action 2.0 cli command "conf t"
action 3.0 cli command "no ip route 0.0.0.0 0.0.0.0 FastEthernet0/0.11 dhcp 250"
action 4.0 cli command "exit"
action 5.0 cli command "clear ip nat trans forced"
event manager applet onlime-up
event track 1 state up
action 1.0 cli command "enable"
action 2.0 cli command "conf t"
action 3.0 cli command "ip route 0.0.0.0 0.0.0.0 FastEthernet0/0.11 dhcp 250"
action 4.0 cli command "exit"
action 5.0 cli command "clear ip nat trans forced"

Всем спасибо за участие.
0

Поделиться темой:


Страница 1 из 1
  • Вы не можете создать новую тему
  • Вы не можете ответить в тему

1 человек читают эту тему
0 пользователей, 1 гостей, 0 скрытых пользователей